
P ORTANT! - Licensing is NOT 
included in software shipments. See "How to get a license" below  

What's NEW in VERICUT 6.1 

 IMPORTANT! - Licensing is NOT 
included in software shipments. See "How 
to get a license" below for details. 

February 5, 2007 

Dear VERICUT® User: 

Thank you for your continued investment in VERICUT, an important part of your NC 
programming and machining process! 

The VERICUT 6.1 NC simulation, verification, and optimization technology is packed with 
new features making it more powerful and easier to use. This letter describes important 
changes in VERICUT 6.1. Take a moment to review what's new and improved in this 
release. 

Maintenance and Licensing Information 

  
Software maintenance keeps you on the cutting edge - CGTech provides update software to 
customers with current software maintenance. Your continued maintenance ensures that you 
have the most advanced verification technology available. If your maintenance has expired, 
please contact your CGTech representative (www.cgtech.com/email.htm). 

Sincerely, 

Bill Hasenjaeger 

CGTech Product Marketing 

How To Get a License - All users must complete and return the License Request Form 
in the CD booklet, or submit the application at http://www.cgtech.com/license/. 
Licensing is sent via Email only.  

NOTE:  Use only 6.1 licensing with this software. 

http://www.cgtech.com/email.htm
http://www.cgtech.com/license/


VERICUT 6.1 
Release Notes 
February 5, 2007 
  
 
Over 140 customer reported problems and 80 customer requested enhancements have been 
implemented in VERICUT 6.1. The following is a summary of enhancements. 

 

VERICUT 6.1 Enhancements 

NC Program Review 

In VERICUT 6.1 NC program Review uses VERICUT's desktop and graphics, it no 
longer opens in a separate window. It is combined with the Info NC Program display. An 
icon button in the Info NC Program window switches modes between the Info display 
and the Review display. When in Review mode, simulation is disabled and the user can 
navigate backwards from the last NC program line simulated. 
 
Entering Review mode adds Step Backward and Play Backward buttons to VERICUT's 
other VCR buttons. The existing Step, Play, Rewind and Reset buttons also change to 
interact in Review mode. 
 
Both machine views and profile views are now active in Review mode, including an 
option tool path line display in the profile view.  
 
When stepping, or playing backwards, the machine can also be animated by optionally 
enabling File > Properties > Animate Machine When Stepping Back. This optional 
choice uses additional memory to store the machine locations for backwards animation. 
Only motions simulated after this option is enabled are stored for backwards animation. 
 
Material can also be added back to the cut stock when stepping back, by optionally 
enabling File > Properties > Replace Material When Stepping Back. This optional choice 
uses additional memory to store the material for backwards animation. 500 backwards 
steps are stored. Only material removed after this option is enabled are stored for 
backwards animation. 

 
Synchronized subsystem simulation (such as for multi-channel controls) can now be 
displayed in Review mode. 
 
Tool information is displayed below the NC program text when in Review mode. 



 
Error text is highlighted when an error mark on the stock or fixture (usually red color) is 
selected in a workpiece view while in Review mode. 

AUTO-DIFF 

AUTO-DIFF Constant Gouge Check can optionally check for a minimum amount of 
excess material relative to the design model. This is typically used where roughing cuts 
should leave a specific minimum amount of material for subsequent machining. 
 
AUTO-DIFF profile is improved to detect very small differences and avoid reporting 
"false errors" associated with the design and cut stock profiles being nearly coincident. 
 
 

Protecting Machine and Control Configurations 

Encrypted machine and control files may be optionally created and used. The encrypted 
files cannot be modified. Menu features are reorganized so "project-specific" settings, 
and "machine/control-specific" settings are clearly separated. When using encrypted 
machine/control files the machine/control menus are disabled. 
 
An environment variable, CGTECH_MACHINE_CONFIG, can be set to FALSE to 
completely remove the machine/control Configuration menu from VERICUT's main 
menu bar. 

 
 

MDI Dialogue 

MDI is significantly enhanced to include axis jog buttons and tool positioning by 
graphical picks. 

 
 

CAD/CAM Interfaces 

The Unigraphics interface merges tools from the UG session with tools in the template 
project file's Tool Library. 

 
CATV allows users to choose how to apply the part operation’s machining axis in their 
VERICUT simulation, by selecting the offset table (Program Zero, Work Offset, etc.) and 
relationship to the machine (tool, rotary axis pivot, etc.). 
 
CATV allows the user to select sketch geometry used to define tool shapes in CATIA (in 
CUT and NO CUT sketch profiles). The geometry is used to create tools in VERICUT. 



 
CATIA length units (inch or millimeter) is now automatically detected and set in the 
VERICUT session. 

 
 

Tools 

Turning tools with multiple inserts (such as "Flash" tools or other types of tools with 
multiple inserts) are now supported, including definition of multiple driven points. Each 
insert's position is checked for valid turning orientation, and must lie in a valid turning 
plane before it will cut. 
 
Cutting limit checking (added in 6.0) is enhanced to include checking 
Minimum/Maximum RPM values. 
 
A new Tool Manger menu, View > Allocate Width to Columns, fits tool columns to the 
window layout. 
 
A new modal choice automatically creates a milling tool's gage location at the highest 
point on the tool assembly. Tool Manager menu Edit > Automatic Gage Offset Z is a 
toggle button. The button state is stored in the user's prefs file. When on, the gage offset 
Z is automatically positioned to the highest point of the tool assembly whenever a tool 
component is modified. Only the Z value is modified, preserving the existing XY. This 
feature only applies to milling tools. 

 
 

Status Lights 

More VERICUT status lights are added to indicate activity during simulation.  
 
The Busy light stays on when VERICUT is loading models. 

 
 
  

Siemens 840D VNCK 

The Siemens 840D VNCK uses a new VERICUT simulation API. The simulation API 
allows an external program to control the VERICUT simulation. 
 
VERICUT uses VNCK version 1.5. 
 
VERICUT uses the VNCK's ISV licensing model. 

 



 

Error Message Display 

A new logger display now shows messages in a scrolling list. Messages are organized by 
category: Information, Warning, Error. Each category of message can be blanked or 
displayed via right-mouse menu or View > Logger View Options. Selecting an error or 
warning message in the list highlights the associated NC program line in the NC program 
display. The logger display is a dockable panel and can be located horizontally within the 
desktop, or outside the desktop. 
 
Logger and log file messages are more consistent. 
 
Duplicate messages for one NC program record are eliminated (such as collision errors 
reported twice during a Drilling Cycle). 
 
The logger now behaves correctly with Step and Play. 
 
The logger correctly displays "End of file". 
 
Collision messages indicate whether a HOLDER or SHANK collides. 

 
 

Mouse Button and View Dynamics 

Mouse dynamic view is modified to work "one-handed" as follows: 
Left button – Rotate 
Middle button – Zoom to box 
Right button - Pan 
Mouse wheel – Zoom in/out 

 
The original mouse button controls still work: 

Shift + left button – Pan 
Control + left button – Zoom in/out 
Control + shift + left button – Rotate 

 
 

Miscellaneous Enhancements 

The memory available to VERICUT's display and GUI (via Java runtime parameters 
Xmx, Xms, and Xss) is increased for improved stability. 
 
Info > G-Code Report and Control Report now open the report in a text editor without 
forcing the user to save a file. 



 
Floor/Wall texture files are configurable in the View Attributes dialogue under a new 
OpenGL Settings tab. Initial texture files are show if the environment variables are set. 
 
The Status window now displays axis positions with 8 decimal place accuracy. Trailing 
zeros are suppressed. 
 
The File > Merge menu in Tool Manager combines a "Master" tool library file with 
another tool library file, creating a 3rd "Merged" tool library file. Options are available for 
the disposition of duplicate tool ID's. 
 
Added support for Sinumerik 840D DEFINE AS variable substitution. 
 
The VERICUT main window stays behind the image playback windows. Behavior of the 
status window with playback is also improved. 
 
Project Tree text color highlighting is enhanced. 
 
The user can now specify the number of Recent Files to display and can clear the list. 
 
Cutting graphs only displays subsystems that are being synchronized. Display of 
"auxiliary" subsystems, such at tool changers, pallet changers, etc, are not displayed. 
 
Probing now works correctly with rotation planes active. 
 
Project > Setup Models > Define now displays only components and models of the 
current setup. 
 
A new environment variable CGTECH_VIEWER is added to specify the editor to be 
used when viewing any text files. 
 
Added a new Translucent choice to component Mixed Mode visibility in the modeling 
dialogue. Translucency is only valid for Accelerated views set to Mixed display mode. 
The View > Attributes > OpenGL settings has a Translucency slider to control the objects 
translucency. 
 
A Model Auto Block button is added to the Model Definition > Model tab. When pressed 
the button calculates a block enveloping the models of the first Design component in the 
tree. The offset value is applied. The former Auto Block button is renamed to Path Auto 
Block to indicate the block size created by this button is based on the NC Program file. 
 
Added an icon to the tool bar to enable the No Animation option from Project > 
Processing Options > Motion. 
 
A new Autosave file naming scheme is implemented in order to create unique file names. 
Files created by Autosave are now named as follows: 



 
Filename#S#F#Tid.ext 
 

Filename is the name specified in the Autosave dialogue 

# is a unique sequential file counter, start with 1, reset to 1 on VERICUT reset 

S# is setup index number 

F# is the toolpath file index number 

Tid is the tool id, omitted if not using a tool library 

.ext is the default file extention of ps, eps, tif, jpg, etc. depending on the file being 
saved and if not specified in Filename 

 
AVI record/playback now records a Profile view. 
 
The Mold & Die product license is retired. 
 
The Advanced Machine Features license is retired. All features formerly under this 
license are now available with the Verification base license. 
 
The number of facet normals fixed by Polyfix is now displayed in the polyfix log file. 
 
The Collision Table contents are now divided between the machine file and project file’s 
setup depending on the component pairs. 
 
VERICUT optional and debug environment variables are now included as comments in 
VERICUT run scripts. 

 
 

Corrections 

Some sites have been experiencing "random" unexpected VERICUT termination. A 
"random" unexpected VERICUT termination is defined as one that is not repeatable and 
cannot be duplicated. Significant effort has been made to identify, and eliminate, possible 
sources of these random terminations and thereby improving the stability of VERICUT. 
 
NC Program Review display inconsistencies, seen during multiple Step Forward/Step 
Backward picks, are fixed. 
 
Coordinate system preview symbol display inconsistencies are corrected. 
 
Tool display error in the workpiece view associated with tool orientation rotation, rotary 
axis motion and spindle on command is fixed. 
 
Cuttercomp now works correctly with polar motion. 



 
Circular motion while in cylindrical interpolation mode is fixed. 
 
Helical motion after Z axis motion while cutter compensation is active now works 
correctly. 
 
Milling tool wizard correctly places inserts when helix angle is zero. 
 
Status window now show the correct IPM when FeedPerMinuteType is set and cutter 
compensation is active.  
 
VERICUT processes correctly with multiple insert/cutter tool. 
 
VERICUT correctly executes OptiPath Learn mode when the process tree is open. 
 
VERICUT correctly continues processing after pressing OK in Model Export’s Preview 
and Combine dialogue. 
 
A problem in VERICUT’s motion break-up logic associated with the speed slider is 
fixed. 
 
NC Toolpaths are now displayed in CATV’s files selection box in alpha order, rather 
than the previous random order received from CATIA. 
 
CATV opens VERICUT with the updated setup template tool library created during 
previous runs when the user selects “Use tool library referenced by setup template”. 
 
It is now possible to use a VERICUT sweep file as an Insert Cutter for turning. 
 
Inspection correctly maintains a feature’s position when the view is rotated and the 
feature location is refreshed. 
 
Duplicate R values are no longer output in the optimised NC program file when Optimise 
Circles is turned on. 
 
CycleMillPocketCutType with override value of 2 or 4 is now working correctly when 
stepover is zero. 
 
Tree display modified, and highlight color is added, for better character clarity. 
 
Motion > Tool Spindle Always On option no longer requires the user to press Reset to 
activate. 
 
Improvements to memory allocation allow larger VCT model to work correctly as 
fixtures. 
 



The Mastercam interface now correctly transfers NC program information to VERICUT 
when operations are in sub groups. 
 
STL Normals set to Computed in model definition is now correctly saved in the machine 
file. 
 
Motion > Tool Spindle Always On option works for all NC program files being 
processed. 
 
Fanuc G71 Rough Turn cycle emulation now correctly determines turning (OD) vs. 
boring (ID) based on the relative positions of the starting and ending X values. 
 
VERICUT now correctly sets the spindle speed based on the active spindle when in units-
per-revolution feed mode, and running a sync job.  This corrects the time and the display 
in the Tool Use graph. 
 
The EdgeCAM interface has been updated to version 10.75. A problem in the menu is 
caused by EdgeCAM and will be fixed in version 11.00. A new VERICUT menu has 
been added to work around this problem. 
 
VERICUT correctly removes material, including during circular motion, with a complex 
turning insert consisting of multiple concavities.  
 
Mixing cutter and holder components in a tool list (cutter A and holder B) is improved. 
However this practice is not recommended since the desired tool assembly in the machine 
view cannot always be determined. Correctly configuring the tools in Tool Manager is 
the recommended method. 
 
Two heads processing a G28 ReferencePointIndex motion simultaneously during sync 
motion now works correctly. 
 
CATV now correctly writes higher-order ASCII characters to the VERICUT project file, 
allowing labels to include these characters (such as ü). 
 
The default action for an NC program in VERICUT’s project tree is now a text editor. 
This causes a double-click on the NC program file name to open the file in a text editor. 
 
A problem causing incorrect emulation of Heidenhain iTNC 530 pocket cycle def 4 under 
specific conditions is now fixed. 
 
A geometry inconsistency problem in DXF tool profile causing the resulting tool in 
VERICUT to not remove material has been fixed. 
 
A problem with milling tool inserts that intersect the tool centerline causing incorrect 
measurements in X-Caliper has been fixed. 
 



WorkingPlane2ABC works correctly with Local Rotation Plane (ref. Sinumerik 840D 
CYCLE800). 
 
Cutting Graphs now work correctly for tools loaded in two subsystems. 
 
An editing problem in NC Program Review is corrected by reorganization of the NC 
Program Review feature. 
 
RestoreSubsystemID now correctly restores the subsystem when used with After Motion 
during a sync job. 
 
A specific material removal problem affected by the simulation speed slider has been 
corrected. 
 
Fanuc G76 Thread Cycle now works correctly during sync motion. 
 
Fanuc G71 Rough Turn Cycle now works correctly when no motion is on the last 
sequence. 
 
CATV allows the user to specify the G-Code Settings table name to use for program zero. 
The choices can be translated to the local language. 
 
Groove insert geometry adjusted to support the condition where the cutting width equals 
the overall width. 
 
VERICUT correctly processes a complex turning tool shape with multiple concavities. 
 
Importing a setup now uses the same “find file” logic as when opening the project 
containing the setup. 
 
Reports with automatically saved images of tools now work correctly when the control 
uses or NC program uses tool change subroutines. 
 
Problems previously reported with NC Program Review and dynamic view modes are 
corrected by the NC Program Review enhancements. 
 
Tolerance values in initm.Vcproject are corrected to millimeter values. This change 
improves File > New Project > Millimeter, and the behavior with CAD/CAM interfaces 
in millimeter mode. 
 
Problems with the right mouse menu in the Tool Manager when dynamic controls are set 
to CATIA are corrected by the new implementation of mouse buttons and view 
dynamics. 
 



A problem where processing with the VNCK incorrectly indicates "end of file" has been 
corrected by ignoring program stop and end events unless they are part of a VNCRun() 
request. 
 
Pressing Apply during Mate/Align now keeps any constraints previously set. 
 
Zoom to Box icon and action is unavailable when in OpenGL display mode. 
 
Sentinel license administrator WlmAdmin now works correctly for License Server Only 
installs. 
 
NC Program Review incorrect display of circular motion, under specific conditions, is 
corrected. 
 
A problem where Mate/Align fails on the cut stock model has been corrected. 
 
The g-code log file now contains the output results for all NC programs processed for a 
given setup. 
 
VERICUT prompts to save the project file after changing Status or Graph window 
settings. Note that which values to graph, and their maximums, are saved in the user 
preferences. 
 
Sporadic "unable to bind" errors have been eliminated by the use of Java runtime 1.5. 
 
Using SyncValue after setting an offset before motion no longer causes incorrect motion. 
 
Heidenhain cycle 14 / 20 / 22 errors are now correctly written to log file. 
 
Tool Manager middle mouse pick for gage offset location works correctly when dynamic 
controls = CATIA 
 
Now that NC Program Review is in VERICUT’s main desktop, the X-Caliper window no 
longer goes behind the window when active. 
 
A problem causing bad circular motion in the workpiece view with a virtual-Y axis has 
been corrected. 
 
APT FEDRAT/MMPM now correctly output in the optimized NC program file/ 
 
A problem associated with processing Heidenhain iTNC 530 loop count with variables, 
similar to the form L10.Q10, has been fixed. 
 
VERICUT now correctly processes APT SFM spindle command and IPR/MMPR feed 
rates and produces correct cycle times and feed rates for an APT turning. 
 



Added a new DST Ecospeed machine using a virtual C-on-B-on-A head configuration. 
Was previously C-on-A-on-B. 
 
Activating OptiPath from a custom interface now correctly produces an optimized NC 
program file. 
 
VERICUT File Selection Boxes now open with My Network Places contracted if more 
than 16 entries in order to improve speed. 
 
Corrected grinding material removal for special case.  
 
New macros added to enhance the current support of system variables: 
BiDirVarsModeOnOff, BiDirVarsApplyOnOff, BiDirVarsAbsIncr. 
 
Display problems related to using VERICUT solid files from earlier versions have been 
corrected. 
 
Improved material removal display on grinder spiral/helical motion. 
 
The Tool Summary table in the log file now automatically widens based on the longest 
string in the list. 
 
VERICUT no longer incorrectly prompts to save the machine when nothing has changed. 
 
VERICUT image file enhanced to correctly handle various types of view layouts in 
VERICUT’s main desktop. 
 
Animation Speed slider now correctly affects turning motions. 

 
 

Training Sessions 

All training sessions are updated for V6.1 and include separate sections for Verification 
and for Machine and Control Configuration. 
 
 

VERICUT Help 

VERICUT Online Help is PDF file based for V6.1. 
 

 



New Macros / Conditionals in V6.1 
BiDirVarsAbsIncr 

BiDirVarsApplyOnOff 

BiDirVarsModeOnOff 

CycleMillCenterAbscissa 

CycleMillCenterOrdinate 

CycleMillThread 

CycleMillThreadDir 

CycleMillThreadFeed 

CycleMillThreadID 

CycleMillThreadOD 

CycleMillThreadPitch 

CycleMillThreadToolTeeth 

CycleTurnAdjustEndPoint 

EI_RetractRadius 

IJKVector 

IJKVector2 

SetMaxMotionDistance 

SiemensCornerValue840D 

TapeCacheCheck 

TapeCachePoint 

TapeCacheTows 

TapeDensity 

TapeHead 

TapeHeadService 

TapeInitialLength 

TapeLayer 

TapePath 

TapePly 

TapeReloadAllTows 

TapeReloadTow 

TapeThickness 



TapeTotalTows 

TapeTowOff 

TapeTowOn 

TapeTows 

TapeTowSwitches 

TapeTowWidth 

TriceptDriveCenterpost 

TripodArmLength 

TripodRodLength 

TurnOnOffCompTravelLimits 

TurnOnOffSubsystemTravelLimits 

WorkingPlane2AbcSolution 
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