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July 16, 2007 

Dear VERICUT® User: 

Thank you for your continued investment in VERICUT, an important part of your NC 
programming and machining process! 

The VERICUT 6.1 NC simulation, verification, and optimization technology is packed with 
new features making it more powerful and easier to use. This letter describes important 
changes in VERICUT 6.1. Take a moment to review what's new and improved in this 
release. 

Maintenance and Licensing Information 

  
Software maintenance keeps you on the cutting edge - CGTech provides update software to 
customers with current software maintenance. Your continued maintenance ensures that you 
have the most advanced verification technology available. If your maintenance has expired, 
please contact your CGTech representative (http://cgtech.com/usa/cgtech/contact/). 

Sincerely, 

Bill Hasenjaeger 

CGTech Product Marketing 

How To Get a License - All users must complete and return the License Request Form 
in the CD booklet, or submit the application at http://cgtech.com/usa/support/license/. 
Licensing is sent via Email only.  

NOTE:  Use only 6.1 licensing with this software. 

http://cgtech.com/usa/cgtech/contact/
http://cgtech.com/usa/support/license/


VERICUT 6.1 
Release Notes 
February 5, 2007 
  
 
Over 140 customer reported problems and 80 customer requested enhancements have been 
implemented in VERICUT 6.1. The following is a summary of enhancements. 

 

VERICUT 6.1 Enhancements 

NC Program Review 

In VERICUT 6.1 NC program Review uses VERICUT's desktop and graphics, it no 
longer opens in a separate window. It is combined with the Info NC Program display. An 
icon button in the Info NC Program window switches modes between the Info display 
and the Review display. When in Review mode, simulation is disabled and the user can 
navigate backwards from the last NC program line simulated. 
 
Entering Review mode adds Step Backward and Play Backward buttons to VERICUT's 
other VCR buttons. The existing Step, Play, Rewind and Reset buttons also change to 
interact in Review mode. 
 
Both machine views and profile views are now active in Review mode, including an 
option tool path line display in the profile view.  
 
When stepping, or playing backwards, the machine can also be animated by optionally 
enabling File > Properties > Animate Machine When Stepping Back. This optional 
choice uses additional memory to store the machine locations for backwards animation. 
Only motions simulated after this option is enabled are stored for backwards animation. 
 
Material can also be added back to the cut stock when stepping back, by optionally 
enabling File > Properties > Replace Material When Stepping Back. This optional choice 
uses additional memory to store the material for backwards animation. 500 backwards 
steps are stored. Only material removed after this option is enabled are stored for 
backwards animation. 

 
Synchronized subsystem simulation (such as for multi-channel controls) can now be 
displayed in Review mode. 
 
Tool information is displayed below the NC program text when in Review mode. 



 
Error text is highlighted when an error mark on the stock or fixture (usually red color) is 
selected in a workpiece view while in Review mode. 

AUTO-DIFF 

AUTO-DIFF Constant Gouge Check can optionally check for a minimum amount of 
excess material relative to the design model. This is typically used where roughing cuts 
should leave a specific minimum amount of material for subsequent machining. 
 
AUTO-DIFF profile is improved to detect very small differences and avoid reporting 
"false errors" associated with the design and cut stock profiles being nearly coincident. 
 
 

Protecting Machine and Control Configurations 

Encrypted machine and control files may be optionally created and used. The encrypted 
files cannot be modified. Menu features are reorganized so "project-specific" settings, 
and "machine/control-specific" settings are clearly separated. When using encrypted 
machine/control files the machine/control menus are disabled. 
 
An environment variable, CGTECH_MACHINE_CONFIG, can be set to FALSE to 
completely remove the machine/control Configuration menu from VERICUT's main 
menu bar. 

 
 

MDI Dialogue 

MDI is significantly enhanced to include axis jog buttons and tool positioning by 
graphical picks. 

 
 

CAD/CAM Interfaces 

The Unigraphics interface merges tools from the UG session with tools in the template 
project file's Tool Library. 

 
CATV allows users to choose how to apply the part operation’s machining axis in their 
VERICUT simulation, by selecting the offset table (Program Zero, Work Offset, etc.) and 
relationship to the machine (tool, rotary axis pivot, etc.). 
 
CATV allows the user to select sketch geometry used to define tool shapes in CATIA (in 
CUT and NO CUT sketch profiles). The geometry is used to create tools in VERICUT. 



 
CATIA length units (inch or millimeter) is now automatically detected and set in the 
VERICUT session. 

 
 

Tools 

Turning tools with multiple inserts (such as "Flash" tools or other types of tools with 
multiple inserts) are now supported, including definition of multiple driven points. Each 
insert's position is checked for valid turning orientation, and must lie in a valid turning 
plane before it will cut. 
 
Cutting limit checking (added in 6.0) is enhanced to include checking 
Minimum/Maximum RPM values. 
 
A new Tool Manger menu, View > Allocate Width to Columns, fits tool columns to the 
window layout. 
 
A new modal choice automatically creates a milling tool's gage location at the highest 
point on the tool assembly. Tool Manager menu Edit > Automatic Gage Offset Z is a 
toggle button. The button state is stored in the user's prefs file. When on, the gage offset 
Z is automatically positioned to the highest point of the tool assembly whenever a tool 
component is modified. Only the Z value is modified, preserving the existing XY. This 
feature only applies to milling tools. 

 
 

Status Lights 

More VERICUT status lights are added to indicate activity during simulation.  
 
The Busy light stays on when VERICUT is loading models. 

 
 
  

Siemens 840D VNCK 

The Siemens 840D VNCK uses a new VERICUT simulation API. The simulation API 
allows an external program to control the VERICUT simulation. 
 
VERICUT uses VNCK version 1.5. 
 
VERICUT uses the VNCK's ISV licensing model. 

 



 

Error Message Display 

A new logger display now shows messages in a scrolling list. Messages are organized by 
category: Information, Warning, Error. Each category of message can be blanked or 
displayed via right-mouse menu or View > Logger View Options. Selecting an error or 
warning message in the list highlights the associated NC program line in the NC program 
display. The logger display is a dockable panel and can be located horizontally within the 
desktop, or outside the desktop. 
 
Logger and log file messages are more consistent. 
 
Duplicate messages for one NC program record are eliminated (such as collision errors 
reported twice during a Drilling Cycle). 
 
The logger now behaves correctly with Step and Play. 
 
The logger correctly displays "End of file". 
 
Collision messages indicate whether a HOLDER or SHANK collides. 

 
 

Mouse Button and View Dynamics 

Mouse dynamic view is modified to work "one-handed" as follows: 
Left button – Rotate 
Middle button – Zoom to box 
Right button - Pan 
Mouse wheel – Zoom in/out 

 
The original mouse button controls still work: 

Shift + left button – Pan 
Control + left button – Zoom in/out 
Control + shift + left button – Rotate 

 
 

Miscellaneous Enhancements 

The memory available to VERICUT's display and GUI (via Java runtime parameters 
Xmx, Xms, and Xss) is increased for improved stability. 
 
Info > G-Code Report and Control Report now open the report in a text editor without 
forcing the user to save a file. 



 
Floor/Wall texture files are configurable in the View Attributes dialogue under a new 
OpenGL Settings tab. Initial texture files are show if the environment variables are set. 
 
The Status window now displays axis positions with 8 decimal place accuracy. Trailing 
zeros are suppressed. 
 
The File > Merge menu in Tool Manager combines a "Master" tool library file with 
another tool library file, creating a 3rd "Merged" tool library file. Options are available for 
the disposition of duplicate tool ID's. 
 
Added support for Sinumerik 840D DEFINE AS variable substitution. 
 
The VERICUT main window stays behind the image playback windows. Behavior of the 
status window with playback is also improved. 
 
Project Tree text color highlighting is enhanced. 
 
The user can now specify the number of Recent Files to display and can clear the list. 
 
Cutting graphs only displays subsystems that are being synchronized. Display of 
"auxiliary" subsystems, such at tool changers, pallet changers, etc, are not displayed. 
 
Probing now works correctly with rotation planes active. 
 
Project > Setup Models > Define now displays only components and models of the 
current setup. 
 
A new environment variable CGTECH_VIEWER is added to specify the editor to be 
used when viewing any text files. 
 
Added a new Translucent choice to component Mixed Mode visibility in the modeling 
dialogue. Translucency is only valid for Accelerated views set to Mixed display mode. 
The View > Attributes > OpenGL settings has a Translucency slider to control the objects 
translucency. 
 
A Model Auto Block button is added to the Model Definition > Model tab. When pressed 
the button calculates a block enveloping the models of the first Design component in the 
tree. The offset value is applied. The former Auto Block button is renamed to Path Auto 
Block to indicate the block size created by this button is based on the NC Program file. 
 
Added an icon to the tool bar to enable the No Animation option from Project > 
Processing Options > Motion. 
 
A new Autosave file naming scheme is implemented in order to create unique file names. 
Files created by Autosave are now named as follows: 



 
Filename#S#F#Tid.ext 
 

Filename is the name specified in the Autosave dialogue 

# is a unique sequential file counter, start with 1, reset to 1 on VERICUT reset 

S# is setup index number 

F# is the toolpath file index number 

Tid is the tool id, omitted if not using a tool library 

.ext is the default file extention of ps, eps, tif, jpg, etc. depending on the file being 
saved and if not specified in Filename 

 
AVI record/playback now records a Profile view. 
 
The Mold & Die product license is retired. 
 
The Advanced Machine Features license is retired. All features formerly under this 
license are now available with the Verification base license. 
 
The number of facet normals fixed by Polyfix is now displayed in the polyfix log file. 
 
The Collision Table contents are now divided between the machine file and project file’s 
setup depending on the component pairs. 
 
VERICUT optional and debug environment variables are now included as comments in 
VERICUT run scripts. 

 
 

Corrections 

Some sites have been experiencing "random" unexpected VERICUT termination. A 
"random" unexpected VERICUT termination is defined as one that is not repeatable and 
cannot be duplicated. Significant effort has been made to identify, and eliminate, possible 
sources of these random terminations and thereby improving the stability of VERICUT. 
 
NC Program Review display inconsistencies, seen during multiple Step Forward/Step 
Backward picks, are fixed. 
 
Coordinate system preview symbol display inconsistencies are corrected. 
 
Tool display error in the workpiece view associated with tool orientation rotation, rotary 
axis motion and spindle on command is fixed. 
 
Cuttercomp now works correctly with polar motion. 



 
Circular motion while in cylindrical interpolation mode is fixed. 
 
Helical motion after Z axis motion while cutter compensation is active now works 
correctly. 
 
Milling tool wizard correctly places inserts when helix angle is zero. 
 
Status window now show the correct IPM when FeedPerMinuteType is set and cutter 
compensation is active.  
 
VERICUT processes correctly with multiple insert/cutter tool. 
 
VERICUT correctly executes OptiPath Learn mode when the process tree is open. 
 
VERICUT correctly continues processing after pressing OK in Model Export’s Preview 
and Combine dialogue. 
 
A problem in VERICUT’s motion break-up logic associated with the speed slider is 
fixed. 
 
NC Toolpaths are now displayed in CATV’s files selection box in alpha order, rather 
than the previous random order received from CATIA. 
 
CATV opens VERICUT with the updated setup template tool library created during 
previous runs when the user selects “Use tool library referenced by setup template”. 
 
It is now possible to use a VERICUT sweep file as an Insert Cutter for turning. 
 
Inspection correctly maintains a feature’s position when the view is rotated and the 
feature location is refreshed. 
 
Duplicate R values are no longer output in the optimised NC program file when Optimise 
Circles is turned on. 
 
CycleMillPocketCutType with override value of 2 or 4 is now working correctly when 
stepover is zero. 
 
Tree display modified, and highlight color is added, for better character clarity. 
 
Motion > Tool Spindle Always On option no longer requires the user to press Reset to 
activate. 
 
Improvements to memory allocation allow larger VCT model to work correctly as 
fixtures. 
 



The Mastercam interface now correctly transfers NC program information to VERICUT 
when operations are in sub groups. 
 
STL Normals set to Computed in model definition is now correctly saved in the machine 
file. 
 
Motion > Tool Spindle Always On option works for all NC program files being 
processed. 
 
Fanuc G71 Rough Turn cycle emulation now correctly determines turning (OD) vs. 
boring (ID) based on the relative positions of the starting and ending X values. 
 
VERICUT now correctly sets the spindle speed based on the active spindle when in units-
per-revolution feed mode, and running a sync job.  This corrects the time and the display 
in the Tool Use graph. 
 
The EdgeCAM interface has been updated to version 10.75. A problem in the menu is 
caused by EdgeCAM and will be fixed in version 11.00. A new VERICUT menu has 
been added to work around this problem. 
 
VERICUT correctly removes material, including during circular motion, with a complex 
turning insert consisting of multiple concavities.  
 
Mixing cutter and holder components in a tool list (cutter A and holder B) is improved. 
However this practice is not recommended since the desired tool assembly in the machine 
view cannot always be determined. Correctly configuring the tools in Tool Manager is 
the recommended method. 
 
Two heads processing a G28 ReferencePointIndex motion simultaneously during sync 
motion now works correctly. 
 
CATV now correctly writes higher-order ASCII characters to the VERICUT project file, 
allowing labels to include these characters (such as ü). 
 
The default action for an NC program in VERICUT’s project tree is now a text editor. 
This causes a double-click on the NC program file name to open the file in a text editor. 
 
A problem causing incorrect emulation of Heidenhain iTNC 530 pocket cycle def 4 under 
specific conditions is now fixed. 
 
A geometry inconsistency problem in DXF tool profile causing the resulting tool in 
VERICUT to not remove material has been fixed. 
 
A problem with milling tool inserts that intersect the tool centerline causing incorrect 
measurements in X-Caliper has been fixed. 
 



WorkingPlane2ABC works correctly with Local Rotation Plane (ref. Sinumerik 840D 
CYCLE800). 
 
Cutting Graphs now work correctly for tools loaded in two subsystems. 
 
An editing problem in NC Program Review is corrected by reorganization of the NC 
Program Review feature. 
 
RestoreSubsystemID now correctly restores the subsystem when used with After Motion 
during a sync job. 
 
A specific material removal problem affected by the simulation speed slider has been 
corrected. 
 
Fanuc G76 Thread Cycle now works correctly during sync motion. 
 
Fanuc G71 Rough Turn Cycle now works correctly when no motion is on the last 
sequence. 
 
CATV allows the user to specify the G-Code Settings table name to use for program zero. 
The choices can be translated to the local language. 
 
Groove insert geometry adjusted to support the condition where the cutting width equals 
the overall width. 
 
VERICUT correctly processes a complex turning tool shape with multiple concavities. 
 
Importing a setup now uses the same “find file” logic as when opening the project 
containing the setup. 
 
Reports with automatically saved images of tools now work correctly when the control 
uses or NC program uses tool change subroutines. 
 
Problems previously reported with NC Program Review and dynamic view modes are 
corrected by the NC Program Review enhancements. 
 
Tolerance values in initm.Vcproject are corrected to millimeter values. This change 
improves File > New Project > Millimeter, and the behavior with CAD/CAM interfaces 
in millimeter mode. 
 
Problems with the right mouse menu in the Tool Manager when dynamic controls are set 
to CATIA are corrected by the new implementation of mouse buttons and view 
dynamics. 
 



A problem where processing with the VNCK incorrectly indicates "end of file" has been 
corrected by ignoring program stop and end events unless they are part of a VNCRun() 
request. 
 
Pressing Apply during Mate/Align now keeps any constraints previously set. 
 
Zoom to Box icon and action is unavailable when in OpenGL display mode. 
 
Sentinel license administrator WlmAdmin now works correctly for License Server Only 
installs. 
 
NC Program Review incorrect display of circular motion, under specific conditions, is 
corrected. 
 
A problem where Mate/Align fails on the cut stock model has been corrected. 
 
The g-code log file now contains the output results for all NC programs processed for a 
given setup. 
 
VERICUT prompts to save the project file after changing Status or Graph window 
settings. Note that which values to graph, and their maximums, are saved in the user 
preferences. 
 
Sporadic "unable to bind" errors have been eliminated by the use of Java runtime 1.5. 
 
Using SyncValue after setting an offset before motion no longer causes incorrect motion. 
 
Heidenhain cycle 14 / 20 / 22 errors are now correctly written to log file. 
 
Tool Manager middle mouse pick for gage offset location works correctly when dynamic 
controls = CATIA 
 
Now that NC Program Review is in VERICUT’s main desktop, the X-Caliper window no 
longer goes behind the window when active. 
 
A problem causing bad circular motion in the workpiece view with a virtual-Y axis has 
been corrected. 
 
APT FEDRAT/MMPM now correctly output in the optimized NC program file/ 
 
A problem associated with processing Heidenhain iTNC 530 loop count with variables, 
similar to the form L10.Q10, has been fixed. 
 
VERICUT now correctly processes APT SFM spindle command and IPR/MMPR feed 
rates and produces correct cycle times and feed rates for an APT turning. 
 



Added a new DST Ecospeed machine using a virtual C-on-B-on-A head configuration. 
Was previously C-on-A-on-B. 
 
Activating OptiPath from a custom interface now correctly produces an optimized NC 
program file. 
 
VERICUT File Selection Boxes now open with My Network Places contracted if more 
than 16 entries in order to improve speed. 
 
Corrected grinding material removal for special case.  
 
New macros added to enhance the current support of system variables: 
BiDirVarsModeOnOff, BiDirVarsApplyOnOff, BiDirVarsAbsIncr. 
 
Display problems related to using VERICUT solid files from earlier versions have been 
corrected. 
 
Improved material removal display on grinder spiral/helical motion. 
 
The Tool Summary table in the log file now automatically widens based on the longest 
string in the list. 
 
VERICUT no longer incorrectly prompts to save the machine when nothing has changed. 
 
VERICUT image file enhanced to correctly handle various types of view layouts in 
VERICUT’s main desktop. 
 
Animation Speed slider now correctly affects turning motions. 

 
 

Training Sessions 

All training sessions are updated for V6.1 and include separate sections for Verification 
and for Machine and Control Configuration. 
 
 

VERICUT Help 

VERICUT Online Help is PDF file based for V6.1. 
 

 



New Macros / Conditionals in V6.1 
42 new macros are added for V6.1. 

 

BiDirVarsAbsIncr 

BiDirVarsApplyOnOff 

BiDirVarsModeOnOff 

CycleMillCenterAbscissa 

CycleMillCenterOrdinate 

CycleMillThread 

CycleMillThreadDir 

CycleMillThreadFeed 

CycleMillThreadID 

CycleMillThreadOD 

CycleMillThreadPitch 

CycleMillThreadToolTeeth 

CycleTurnAdjustEndPoint 

EI_RetractRadius 

IJKVector 

IJKVector2 

SetMaxMotionDistance 

SiemensCornerValue840D 

TapeCacheCheck 

TapeCachePoint 

TapeCacheTows 

TapeDensity 

TapeHead 

TapeHeadService 

TapeInitialLength 

TapeLayer 

TapePath 

TapePly 

TapeReloadAllTows 



TapeReloadTow 

TapeThickness 

TapeTotalTows 

TapeTowOff 

TapeTowOn 

TapeTows 

TapeTowSwitches 

TapeTowWidth 

TriceptDriveCenterpost 

TripodArmLength 

TripodRodLength 

TurnOnOffCompTravelLimits 

TurnOnOffSubsystemTravelLimits 

WorkingPlane2AbcSolution 
 

 



VERICUT 6.1.1 Interim Release 
Release Notes 
May 2, 2007 
 
VERICUT Version 6.1.1 contains everything described above for V6.1, plus these additional 
fixes/enhancements. 
 

AUTO-DIFF 

Compare, Restore, and Report buttons in the AUTO-DIFF window now update correctly 
when the Stock Component field is changed. 
 

CATIA V5-to-VERICUT Interface 

Models no longer disappear from CATV5 created projects, when OpenGL is turned on. 

A problem causing CATV5 to incorrectly orient turning tools rotated 180 degrees about X is 
fixed. 

CATV5 is enhanced to look for the information that may have been established for CATIA's 
own "tool path replay" when a CATProcess file has not been handled by CATV before, and 
thus does not have the CGTech attributes that provide the names of the selected 
design/stock/fixture models. 

 

EdgeCAM-to-VERICUT Interface 

The EdgeCAM 11 to VERICUT Interface created Tool Library ID's now match those in 
EdgeCAM. 

The EdgeCAM 11 to VERICUT Interface no longer outputs false errors and correctly starts 
VERICUT. 

The EdgeCAM to VERICUT Interface has been updated to refer to VcProject files instead of 
User files. 

The EdgeCAM 11 to VERICUT Interface now correctly applies the same offset to NC Zero 
as it does to the models. 

 



GibbsCAM-to-VERICUT Interface 

A GibbsCAM to VERICUT interface is added to VERICUT's suite of CAM Interface 
modules. 

 

Machine Simulation 

A condition causing slow VERICUT processing when using certain round insert cutters is 
corrected. 

A problem causing no material removal in the Machine/Cut Stock view for a  specific turning  
setup is fixed. 

A problem preventing material removal and tool display in Work Piece view for a specific 
setup is fixed. 

The VERICUT session no longer "hangs" while processing a specific Probe profile. 

A number of problems related to refreshing the Project Tree, and the NC Program window, 
when transitioning between setups are corrected. 

Edits made to machine and control files are now saved correctly. 

Spindle direction errors are now correctly reported for a specific sub-spindle configuration. 

MDI now works correctly for situations when there are no stock or fixture models specified 
and Cutting Tolerance is set to Tool Size. 

A condition causing slow VERICUT processing when the Graphs window is displayed is 
corrected. 

A problem causing unexpected VERICUT termination, under certain conditions, when 
changing to NC Program Review mode is fixed. 

 

MasterCAM-to-VERICUT Interface 

The MasterCAM to VERICUT Interface is enhanced to support MasterCAM X2 resolving 
the following issues: 

• Using either the Apply, or OK, buttons in the MasterCAM to VERICUT Interface no 
longer causes MasterCAM X2 to encounter a problem causing unexpected 
termination when using MasterCAM X2 with the MasterCAM to VERICUT 
Interface. 

• Certain MasterCAM X files no longer cause unexpected MasterCAM X2 termination 
when using MasterCAM X2 with the MasterCAM to VERICUT Interface. 

• Correct stock color to be passed to VERICUT when using MasterCAM X2 with the 
MasterCAM to VERICUT Interface. 



The MasterCAM to VERICUT Interface is enhanced to correctly pass tool information to 
VERICUT for situations where the MasterCAM file contains multiple Machine Groups, that 
use the same tool number, for different tools, used on different machines. 

 

OptiPath 

The OP Graph time is now correct for situations where a subroutine is called multiple times. 

OptiPath has been modified to improve simulation behavior when using Prompt While 
Cutting with the Search OptiPath record window. 

 

Pro/E-to-VERICUT Interface 

The Pro/E to VERICUT interface no longer creates an unused second stock component that 
resulted in no material removal during simulation. 

 

Unigraphics-to-VERICUT Interface 

Parametric Tool calculations that include a draft angle, passed through the Unigraphics to 
VERICUT Interface now output correct diameter changes. 

The Unigraphics to VERICUT interface now includes  XML escape characters for 
special characters when creating VCTMP files. 

The Unigraphics to VERICUT Interface is enhanced to allow the "~" character as part of  a 
tool name. 
The Unigraphics to VERICUT Interface is enhanced to enable creating a CSYS relative to 
another CSYS,  for the purpose of moving the cut stock from one position to the next. 

The OptiPath Description in tool library files generated by the Unigraphics to VERICUT 
Interface are now written in the correct format. 

 

Verification 

The NC Program window now re-opens after closing it via clicking the red "X" box (upper 
right corner of the window) while VERICUT is running. 

Re-opening a .mch file, after saving it as in encrypted file, no longer outputs false errors that 
models cannot be found. 

Changing "Dynamic Rotation" features while in OpenGL mode now works correctly. 

The "Zoom' function now works correctly when View > Dynamic Controls is set to 
Unigraphics. 



In the Project Tree, files can now be pasted to an NC Subroutines branch. 

The Workpiece View display no longer "flickers" when you start/stop dragging the mouse 
when using "Dynamic Rotation" features while in OpenGL mode. 

VERICUT now simulates the toolpath correctly when rotating about C axis only (small 
increment only) after helical milling. 

Using a spaceball rotation in a Workpiece View, while in OpenGL mode no longer causes 
excessive screen "flashing". 

A problem causing incorrect concatenation of  alpha-numeric, and numeric, variables is 
fixed. 

The VERICUT session no longer "hangs" while stepping through a specific subroutine with 
the Variables window and the Machine Offsets window open. 

Invalid "Cutter Compensation produced negative radius" errors, due to rounding differences 
in VERICUT, are no longer reported. 

Random unexpected VERICUT termination no longer occurs when loading a specific project 
file. 

The MDI feature, Orient Tool Axis now works correctly with 4-axis machines. 

Individual NC programs, in multiple NC program setups, now process correctly when the 
other NC programs are designated as inactive. 

When using a tool list to add holder to a cutter defined in APT, the holder is now stacked on 
the cutter as it was in pre-V6 VERICUT. 

Single stepping through a multiple NC program setup now transitions correctly from one NC 
program to the next. 

NC Program Review is enhanced to display the design in a Profile View, along with the 
Stock, Tool, and tool path line trace. 

Reset Cut Color no longer changes the original colors of the VERICUT Solid (.vct) model in 
a refined Workpiece View. 

VERICUT now prompts you when tool libraries are not found. 

A problem causing false "Collision between Cutter of the tool............" errors for all except 
the initial NC program, in multiple NC program setups, when "Tool Spindle Always On" is 
toggled on is fixed. 

VERICUT reports, in PDF format, now generate when a setup is designated as inactive. 

A problem causing intermittent unusual behavior when using the dynamic rotate/pan/zoom 
mouse controls  when View > Dynamic Controls is set to VERICUT is fixed. 

The Override Format feature, in the Add/Modify Word/Address window, is now ignored if 
the input text is not all numeric. 

The mouse thumbwheel now becomes inactive when any other mouse button is pushed 
during a simulation. 



Cutter compensation is no longer ignored on the first block after it is invoked when using an 
inserted milling tool. 

A problem preventing using the Modeling window to move a stock/fixture/design model 
using a pick on a machine model, while the Project Tree is open, is fixed. 

False holder/workpiece collision errors, for situations where the tool axis is very close, but 
not quite aligned with, a major axis, are no longer reported. 

Unexpected VERICUT termination no longer occurs when using a Magellan serial 
SpaceMouse. 

Turning holder/stock collision error reporting is now more consistent when a  Near Miss 
Value is in effect. 

The NC Program window can now be re-displayed after it was closed using the red "close" 
button in the top right corner of the window. 

When a CSYS is renamed in the Project Tree, the original name is now cleared from the 
graphics display before the new name gets displayed. 

Components no longer fail to display red when a collision occurs when both the Driven Point 
axis is displayed and OpenGL is turned on in a Machine View. 

A bad cutter display, and incorrect material removal, for a specific project file is corrected. 

The IP file name buffer is cleared when opening a VcProject file unless the VcProject file 
being opened has an IP filename saved inside it. 

Material removal is now correct for a specific lathe parting operation. 

Stock no longer gets blanked when a turning spindle spins when the Model Tolerance in the 
project file is set to zero. 

OpenGL texture files on the "Copy Files" window are now defaulted so that their check 
boxes are "unchecked". 

"Active" model indicators are now consistent between the Project Tree, Modeling window, 
and the graphics area are now consistent. 

Unexpected VERICUT termination no longer occurs when using a SpaceTraveler spaceball  
after rotating, then picking a point on the model in a Workpiece View when selecting From 
and To points on the Modeling window, Position tab. 

Unexpected VERICUT termination no longer occurs when using a SpaceTraveler spaceball  
when rotating in a Workpiece View with OpenGL active. 

VERICUT is enhanced so that you can now both, specify an Override Value, and use the 
Override Format feature, in the Word/Address window. 

Conflicting results between a profile view, and an equivalent section view, for a specific part 
no longer occur. 

Material removal in a Workpiece View, and in a Profile View, when cutting a specific arc is 
now consistent. 



The inability to re-size the VERICUT Logger window under certain docking conditions is 
fixed. 

Material removal in the Workpiece View, and the Machine Cut/Stock View, when cutting a 
specific arc is now consistent. 

Incorrect material removal for a specific inserted face mill is corrected. 

Material removal for a specific lathe parting operation is now consistent in the Workpiece, 
Profile, and Machine/Cut Stock views. 

Time calculation is now correct for a specific surface milling operation where the target 
value for x is negative, and spindle is in CSS mode  

 

Miscellaneous 

A new macro, SaveIP, is added to enable saving a VERICUT In-Process (IP) file. 

A new macro, SaveImage, is added to enable saving an image (View Capture) file. 

A new macro, SaveVcSolid, is added to enable saving a VERICUT Solid file. 

Use of the variables E52nnn to create, or modify, the tool cutter compensation on a NUM 
control now creates the Tool Cutter Compensation table entries correctly. 

Macro, SetDynamicVars, CurToolDiam option is enhanced to work with turning inserts. 

A new macro, RenameStocksToDesign, is added to enable automatic renaming of a stock 
component based on the Override Text string plus the name of the first child design 
component of that stock component. 

VERICUT is enhanced to support cycles specified using absolute values for depth. 

PolarXValue, PolarYValue, and PolarZValue macros are enhanced to check if cycles are 
active, and if so, set the cycle depth (as appropriate based on the motion plane). 

The Siemens840D Repeat logic is corrected to search backwards first, and then forwards. 

Reset Cut Color now works correctly for Machine/Cut Stock views when OpenGL is active. 

Macro, SetDynamicVars is enhanced to include a new option, CurToolCornerRadius. This 
feature will get the minimum radius defined for the current tool. This means: 

• The corner radius for a bull end mill. 
• The ball radius for a ball end mill. 
• The corner radius for an insert. 
• The tool radius for a drill. 
• The tool radius for a drill. 
• The minimum radius for a profile with multiple radii. 

Macro, OptiPathOptimizeSubs, using Override Value=5 is modified to better handle 
processing subroutine calls that are multiple levels deep into a subroutine, when some of 
them are job subroutines, and others are control subroutines. 



Library controls fad88.ctl and fad88a.ctl have been modified to recognize the words CLOSE, 
DOOR, and OPEN. 

"$" character is now supported for conditional ranges. 

The "Units" value is now correct in Tool Manager after using Import > DXF Tool for 
millimeter tools. 

Using Replace One in the NC Program Editor no longer results in an 
"ArrayIndexOutOfBoundsException" error. 

When selecting the 'vcp=<file> in the Batch Wizard and you select the Project File to be 
used, the filter is now correctly set to '*.VcProject'. 

Batch Wizard now processes the OS Commands COPY, DELETE, RENAME, and APPEND 
correctly when there is a 'space' in the path or the filename. 

Batch Wizard now processes the OS Command RENAME correctly when the path is 
included in the "To" field. 

Macro, SetDynamicVars is enhanced to include a new option, CurToolRadius to enable 
setting the specified variable number to the current tool radius value. 

The Siemens840DSubroutineSequence macro is enhanced to mark the _MPF program as the 
start of the main program. 

File Selection Box size, location, split-pane position, and table column widths are now saved 
in (and restored from) the preferences file. 

VERICUT now prompts you when tool libraries are not found. 

The default insert thickness used for display purposes when the insert thickness is defined as 
zero is now 3mm, or 0.125 inch, depending on tool unit. 

A problem causing an incorrect tool thumbnail to created in a VERICUT report, for a 
specific tool defined in an APT NC program, is fixed. 

The Using VERICUT section is back in the CGTech Help Library. 

The Sample–Demo Files section in back in the CGTech Help Library. 

Many documentation updates have been added since V6.1. 



 

New Macros in V6.1.1 
RenameStocksToDesign 
SaveImage 
SaveIP 
SaveVcSolid 

 
 
 

VERICUT 6.1.2 Interim Release 
Release Notes 
July 17, 2007 
 
 

VERICUT Version 6.1.2 contains everything described above for V6.1.1, plus these 
additional fixes/enhancements. 

VERICUT Version 6.1.2 is available on all supported hardware platforms (Windows (XP, 
XP64 and Win2000), Sun/Solaris, HP/HPUX, and IBM RS6000/AIX). 

 
NOTES: 
 

1. UNIX Requirements: 
Sun/Solaris 10 (8 or 9 is ok too), JRE 5.0 
HP/HPUX 11.11, JRE 5.0 
RS/AIX  5.2, JRE 5.0 

 
2. If you cannot successfully run the 64bit VERICUT 6.1.2 on Windows XP64: 

You need to install the Microsoft 64 bit C++ run time environment 
(vcredist_x64.exe). This is not distributed automatically by Microsoft.  

Administrator privileges are required to install this.  

You do not need this if you have Microsoft Visual Studio C++ 2005 installed (not 
likely for most VERICUT users).  

This file will be distributed on the VERICUT 6.1.2 CD. 

Although the filename is the same as the one that was needed for the earlier 6.0.x 
versions, it is not the same file.  The earlier 6.0.x versions of vcredist_x64.exe 
will not work with 6.1.2. 

 



3. If you cannot successfully run the MasterCAM-to-VERICUT Interface with 
MasterCAM X2 on Windows XP: 

You need to install the Microsoft 32 bit C++ run time environment 
(vcredist_x86.exe). This is not distributed automatically by Microsoft.  

Administrator privileges are required to install this.  

You do not need this if you have Microsoft Visual Studio C++ 2005 installed (not 
likely for most VERICUT users).  

This file will be distributed on the VERICUT 6.1.2 CD. 
 

AUTO-DIFF 

Unexpected VERICUT termination no longer occurs when using Refine Display after doing 
an AUTO-DIFF surface compare for a specific project file. 
 

CATIA V5-to-VERICUT Interface 

A problem causing a specific tool assembly to be incorrectly rotated 180 degrees when using 
the 'Custom Tools' option in the CATIA V5-to-VERICUT Interface is fixed.  
 

Machine Simulation 

VERICUT no longer stops processing during a G271 turning cycle. 

A problem causing incorrect material removal under certain conditions while processing 
circle records is fixed.   

In-Process files created with OpenGL turned on now open correctly when loaded more than 
once. 

The Selected Model/Component setting in the Modeling window is now correctly set to 
Model, corresponding to the model highlighted in the Component Tree, after it is added.   

 

MasterCAM–to-VERICUT Interface 

The MasterCam-to-VERICUT Interface license is now released correctly after closing the 
MasterCam-to-VERICUT Interface window. 
 

OptiPath 



Unexpected VERICUT termination no longer occurs when optimizing an MCALL 
CYCLE83 statement. 

Helical moves now optimize correctly for G-Code NC programs. 

Unexpected VERICUT termination no longer occurs when using long /path/filenames in the 
Tool Learn Library field on the OptiPath Control window: Learn Mode Options tab. 

OptiPath Learn Mode is enhanced to break up motions exactly the same way that OptiPath 
does during optimization. 

OptiPath processing no longer stops when an APT SPINDL/OFF statement is encountered. 

The Compare NC Programs window now correctly displays, and compares, NC programs 
containing APT SPINDL statements. 

A problem causing OptiPath to create incorrect output blocks for un-optimized tools for a 
specific project file is fixed. 

 

Tool Manager 

The Location Aids feature now correctly re-positions the insert, for inserted milling tools, 
before selecting Modify. 

The Milling Tool Wizard no longer modifies Extension and Holder IDs when New or Close 
is selected.  

Calculate Minimum Cutter Extension is modified to correctly handle tapered profile tools. 

The original tool file is no longer modified when it is used in subsequent setups, modified 
and saved under a different name. 

 

Unigraphics-to-VERICUT Interface 

The original Stock, or Design, model no longer remains highlighted after the Stock, or 
Design, model has been reselected. 

 

Verification 

A problem causing sporadic false errors for specific machine configurations is fixed. 

Unexpected VERICUT termination no longer occurs after adding a setup to a project file 
containing a specific, extremely large G-Code file. 

A problem causing incorrect material removal for a specific, hollow center, profile tool is 
fixed. 

VERICUT's Spatial libraries for CAD Model Interfaces are updated to R17. 



Motion is now correctly generated for Okuma turn Cycle G85 for situations where the start 
point is lower than the end point. 

A problem causing VERICUT to execute a previously used Cutter Compensation command 
when Cutter Compensation is turned on, after the previous Cutter Compensation Off was on 
the same line as the motion command, and the current motion is in a different plane than the 
prior motion, is fixed. 

A problem causing a specific In-Process file to start VERICUT processing at the wrong place 
is fixed. 

A problem causing VERICUT to output the message, "Cycle expansion error - contact 
CGTech" when processing a turning cycle on a Macturn 250, dual channel machine with 
Okuma control is fixed. 

An inserted tool no longer becomes corrupted, after moving the Cut Stock, for a specific 
project file. 

A problem preventing the VERICUT Logger window from being resized, when the NC 
Program window is docked in a specific position, is fixed.  

Material removal with a turning tool when the Stock is not spinning (to simulate a broaching 
operation) is now correct. 

A problem causing incorrect material, when using a specific hollow, inserted face mill during 
circular motion is fixed.  

Material is now removed correctly when the MDI window, Cut Stock option is active and the 
Machine Motion Jog feature is used. 

Unexpected VERICUT termination no longer occurs for a specific project file when the File 
> Save Cut Stock > STL feature is used. 

Graphic display is now consistent in all view types for a specific turning project file. 

APT NC program files listed in the Project > NC Program window are no longer skipped 
during single step processing. 

False "NC Program not Specified" errors are no longer output, when single stepping between 
setups. 

A problem causing incorrect rotation, for a specific boring bar, when executing an M3 
command is fixed. 

A problem resulting in incorrect material removal, for a specific DXF profile drilling tool is 
fixed. 

Adding a Fixture model to a Fixture component no longer incorrectly causes the Design 
component to become highlighted when both the Project Tree and the Component Tree are 
displayed.  

A problem causing the NC Program window to open collapsed, showing only a portion of the 
window header, is fixed. 

The VERICUT session no longer "hangs" when a specific inserted milling tool is used in a 
subsequent setup after moving the Cut Stock. 



VERICUT no longer loses track of a selected model which remains highlighted in the Project 
Tree, after closing the Modeling window. 

A problem causing a corrupt IP file to be created for a specific project file is fixed. 

The axis value now updates correctly, to reflect the current axis position, when switching 
from one subsystem to another in the MDI window. 

Subroutines are now correctly included when saving an encrypted control file. 

Unexpected VERICUT termination, or "hung" sessions, no longer occurs when you try to 
clear the VERICUT message area (logger) during simulation. 

The VERICUT session no longer "hangs" when processing a specific turning project file. 

A problem causing the Cut Stock to disappear, when processing a specific IP file created 
from a CL file based project file, is fixed. 

A problem causing VERICUT to miss a holder collision with the Cut Stock, for a specific 
tool assembly, is fixed 

VERICUT is enhanced so that when Minimum Error Volume is set to zero, VERICUT 
unconditionally reports ALL fast feed and holder collision errors it finds, no matter how 
small the collision volume. 

A problem causing a time delay when opening the MDI window from a "Customizer" user 
interface is fixed. 

A problem causing VERICUT to miss a holder collision and report some false collisions for 
a specific project file is fixed. 

A problem causing incorrect motion and material removal for a specific turning project file is 
fixed. 

A problem causing the Design component to be incorrectly positioned after a reset for a 
specific project file is fixed. 

The VERICUT session no longer "hangs", for situations where the End Sequence number of 
the previous turning cycle is the same as the current sequence number when a new turning 
cycle is turned on. 

The Section glyph no longer remains displayed after the Section window is closed. 

Unexpected VERICUT termination no longer occurs when analyzing a surface using X-
Caliper Feature History, or attempting to define a coordinate system using the center of a 
drilled hole, with a specific VERICUT Solid model. 

VERICUT is enhanced to allow all European accented characters (ä,  ö,  ü, ß, etc.) to be used 
for APT simulation. 

 

Miscellaneous 

Macros CycleTurnAllowanceX, and CycleTurnAllowanceZ, now correctly interpret signed 
(+ or -) input values. 



The Override Text field on the Word/Address Add/Modify window is enhanced to allow the 
incoming text string, and text variables, to be passed as part of an expression. 

The "NumCondEqualWord" conditional function is enhanced such that if the Equal Word 
comes after the string "G79" or if the Equal Word comes after the string "IF" and before the 
word "THEN", then this function returns the type EQ. Otherwise, this function returns the 
type ASSIGNMENT. 

The "NumCondDollarSignWord" conditional function is enhanced such that if the Dollar 
Sign Word comes after a "=", and the previous non-space character is a '+', '-', '*', '/', '=', '<', 
'>, or a '[', then this function returns the type FUNCTION, and sets the word to 
NUM_INPUT. Otherwise this function returns the type CONSOLE_MSG. 

The Heid_CallLbl macro is modified to be dependent on condition of the IF flag set using the 
"If" macros. 

A new Type, "5" is added to the WorkingPlane2AbcType macro to support the special 
double 45 BC nutator found on DMG DMU 50 eVo Linear machines. 

A new macro, HeidMPlusIfCheck, is added to support the Heidenhain MillPlus G29 
command. 

A new Ijk2AbcType, 25, is added to support a BA machine with a nutator. 

A new Word VAR type of "Special" and sub-type "NUM VAR Define" is added to support 
or NUM words VAR (beginning definition of variables) and ENDV (end definition). When 
this word is found, a special parser is used to process the remainder of the statement up to the 
closing word ENDV. This includes the creation and initialization of the numerical variables, 
and the creation of the corresponding words (of type "Special" and sub-type "Variable 
Name"). Word ENDV is part of the NUM VAR Command but it doesn’t have to be specified 
in Word Format table. 

A problem causing inverse motion when Cutter Compensation is used with G71 turning 
cycles is fixed. 

A problem causing all rapid motions when Cutter Compensation is set to 1.6 and is used with 
G71 turning cycles is fixed. 

VERICUT Limited now runs correctly when using APT NC program file with a template 
file. 

Many documentation updates have been added since V6.1.1.  

The VERICUT Macros section of the CGTech Help Library has a new format and many of 
the macro descriptions are enhanced. 

 

New Macros in V6.1.2 

HeidMPlusIfCheck 

VirtualZAxisBRotary 
 



New Macros not yet included in the documentation 

VirtualZAxisBRotary 
Function: Miscellaneous 
Status: Active 
Valid Inputs: None 
 
Establish a virtual Z axis using rotation planes. The input angle is defined by the local B axis 
value. The BAxisMotion macro is used to specify incremental/absolute, and must be called 
prior to calling this macro. This angle defines the angle at which the real Z axis is offset from 
the virtual othogonal Z axis. 
 
The macro Ijk2AbcType has the following new "types": 
 

15. Specific: Old ElectoImpact Tape laying machine 
16. Specific: Old Test Tape laying machine 
17. Specific:  5-axis tripod type mill with a B/A head rotation 
18  Specific:  Tricept machine. 
19. Specific:  ElectroImpact Tape laying machine 
20. Specific:  Tricept machine with no travel limit checks. 
21. Generic:  A 
22. Generic:  B 
23. Generic:  C 
24. Coming in V6.2 
25. Generic:  BA, also support nutator at any angle 
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